Bumblebee – [ERROR]Cannot access secondary GPU – error: [XORG] (EE) Failed to load module „nvidia” (module does not exist, 0)

W sidzie napotkałem ostatnio na wywalenie się bumblebee mimo iż wszystko było wedle starej acz dobrej konifguracji, czyli moduły zbudowane:

    bbswitch, 0.8, 4.6.0-1-amd64, x86_64: installed
    bbswitch, 0.8, 4.8.0-1-amd64, x86_64: installed
    nvidia-current, 367.57, 4.6.0-1-amd64, x86_64: installed
    nvidia-current, 367.57, 4.8.0-1-amd64, x86_64: installed

Poprawnie skonfigurowany /etc/bumblebee.conf/bumblebee.conf.conf z:

Driver=nvidia
KernelDriver=nvidia-current

oraz /etc/bumblebee/xorg.conf.nvidia:

BusID "PCI:07:00:0"

A przy starcie krzyczał, że nie może sobie załadować modułu nvidia:

optirun --status
Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.

optirun -vvv glxgears
[ 4067.950712] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 4067.950993] [INFO]Configured driver: nvidia
[ 4067.951137] [DEBUG]optirun version 3.2.1 starting...
[ 4067.951146] [DEBUG]Active configuration:
[ 4067.951149] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 4067.951153] [DEBUG] X display: :8
[ 4067.951156] [DEBUG] LD_LIBRARY_PATH: /usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/nvidia
[ 4067.951160] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 4067.951163] [DEBUG] Accel/display bridge: auto
[ 4067.951170] [DEBUG] VGL Compression: proxy
[ 4067.951176] [DEBUG] VGLrun extra options:
[ 4067.951180] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/primus:/usr/lib32/primus
[ 4067.951224] [DEBUG]Using auto-detected bridge primus
[ 4068.128154] [INFO]Response: No - error: [XORG] (EE) Failed to load module "nvidia" (module does not exist, 0)

[ 4068.128165] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "nvidia" (module does not exist, 0)

[ 4068.128170] [DEBUG]Socket closed.
[ 4068.128185] [ERROR]Aborting because fallback start is disabled.
[ 4068.128187] [DEBUG]Killing all remaining processes.

lsmod|grep nvid
nvidia              11485184  0

Pomimo iż oczywiście się załadował. Po dłuższej dłubaninie i pytaniach w internetach doszedłem, że sterowniki z w tej wersji w sidzie jakieś niedorobione są i wystarczy zainstalować je z experimentala.

install -t experimental nvidia-driver

Po tym jak ręką odjął, wszystko działa 🙂

downgrade experminetal – unstable

Nie wiem dokładnie jak ja to wczoraj zrobiłem ale z normalną aktualizacją systemu połowa paczek zaciągła się z repo experimental. Czegoś takiego na co dzień nie chcę, wystarczą mi pojedyncze paczki. Ale jak to cofnąć? Niestety nie doszukałem się jakiejś zautomatyzowanej i prostej metody, jedynie manipulacja pinami.

w /etc/apt/preferences dodajem/edytujemy:

Package: *
Pin: release a=unstable
Pin-Priority: 1001

i apt-get upgrade, to powinno zainstalować paczki w wersji z sid’a. Nadal pozostaną jednak w systemie paczki z experimentala które zostały zainstalowane jako zależności a których w sidzie jeszcze nie ma.

Sprawdzamy co zostało:

aptitude search ~S~i~Aexperimental

i w zasadzie możemy je na tym etapie wywalić.