multiarch i broken packages

Przejście na multiarcha jakiś czas temu poszło gładko, powoli coraz więcej paczek aktualizuje się z wersji amd64 do i386 i tu pojawia się problem.

Unpacking replacement libqtgui4:i386 ...
dpkg: error processing /var/cache/apt/archives/libqtgui4_4%3a4.8.2-2+b1_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libqtgui4/changelog.Debian.gz', which is different from other instances of package libqtgui4:i386
Errors were encountered while processing:
 /var/cache/apt/archives/libqtgui4_4%3a4.8.2-2+b1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
dpkg: error processing libqtgui4:amd64 (--configure):
 package libqtgui4:amd64 4:4.8.2-2+b1 cannot be configured because libqtgui4:i386 is at a different version (4:4.8.2-2)

Rozwiązanie bardzo proste, dla każdej takiej paczki wystarczy skasować/zmienić nazwę pliku changelog.Debian.gz znajdującego się w /usr/share/doc/paczka.